fbpx

WC MP Stock Alert conflict with Classima Theme Membership

WCMp Vendor Stock Alert

WC MP Stock Alert conflict with Classima Theme Membership Open

Viewing 1 reply thread
  • Author
    Posts
    • #142190

      I got alerted via wordpress and from my website users when we found that the WCMp Vendor Stock Alert plugin was causing a critical error for my membership feature of Classima Theme. Please refer below, the details of the issue.

      Error Details
      =============
      An error of type E_COMPILE_ERROR was caused in line 50 of the file /home4/funerau4/public_html/wp-content/plugins/wcmp-vendor_stock_alert-master/classes/class-wcmp-vendor-stock-alert-ajax.php. Error message: Unparenthesized

      a ? b : c ? d : e
      Copy

      is not supported. Use either

      (a ? b : c) ? d : e
      Copy

      or

      a ? b : (c ? d : e)
      Copy

      Other Details
      =============
      WordPress version 6.0.2
      Active theme: Classima (version 2.1.8)
      Current plugin: WCMp Vendor Stock Alert (version 1.2.1)
      PHP version 8.0.23

      I have temporarily deactivated the plugin (WC MP Vendor Stock Alert) until the issue is resolved.

      Appreciate if you can check and correct the issue.
      Thanks
      Dominic.

    • #142208

      @Dominic Wickramatunge, may I know which version of PHP are you using in your site so we can check.

      This will help us with the fix.

Viewing 1 reply thread

Please LOGIN to reply to this topic

Buy all Marketplace addons together!!

Check Slashed Price