Vendor requirements

WCMp Mangopay Marketplace

Vendor requirements Open

Viewing 80 reply threads
  • Author
    Posts
    • #94159
      sofi_beker
      Participant

      Hi,

      I would like to make the vendor meet ALL the necesary requirements in his dashboard before beeing able to submit his products. Because at the moment the vendor can upload a product (photo, price and description) and then he is ready to go When in REality, he is missing to complete 2 very important details such us BILLING AND SHIPPING.

      Therefore, i would like to make those two options a requierement before they can submit any product.

      How can i do that?

      Thank yo so much!

    • #94175

      @sofi_beker, thanks for getting in touch with us.

      Currently, shipping and billing are not mandatory. Hence in order to add this, it requires custom code.

      I have forwarded this to our team, they are looking into this. As this needs custom code, hence it might take 2 to 3 days.

      Once I will have the update, will let you know.

    • #94362

      Hi @sofi_beker,
      Use this below code in your current active themes functions.php file to required those fields.

      
      
      /*********************  Shipping mandatory for update product  ************************************/
      add_action( 'wcmp_before_post_update', 'wcmp_before_post_update_callback' );
      function wcmp_before_post_update_callback(){
        
        $billing = metadata_exists( 'user', get_current_user_id(), '_vendor_payment_mode' ) ? get_user_meta( get_current_user_id(), '_vendor_payment_mode',true) : '';
      
        $shipping = isset( $_POST['product_shipping_class'] ) ? $_POST['product_shipping_class'] : '';
      
        $massage = __( 'You have to fill all shipping and billing details' , 'dc-woocommerce-multi-vendor' );
      
        if( empty( $billing ) || $shipping < 1 ) { 
          wc_add_notice( $massage, 'error' );
          wp_redirect( apply_filters( 'wcmp_vendor_save_product_redirect_url', wcmp_get_vendor_dashboard_endpoint_url( get_wcmp_vendor_settings( 'wcmp_edit_product_endpoint', 'vendor', 'general', 'edit-product' ), $_POST['post_ID'] ) ) );
          exit;
        }
      }
      
      
      Copy
    • #94363
      sofi_beker
      Participant

      hi thank you for that!

      where exactly do i need to paste that?

      Thanks again!

    • #94369

      @sofi_beker, add this code in the function.php of the current active theme.

    • #94437
      sofi_beker
      Participant

      thank you!!

    • #94461
      sofi_beker
      Participant

      is this code also for billing mandatory?

    • #94468

      @sofi_beker, this code is only for shipping.

      Our team is checking the code, kindly provide them some time.

    • #94635

      Hi @
      we have updated the code in the previous reply ( #94362 ).Can you please check and keep us posted.

    • #94636
      sofi_beker
      Participant

      got it! thanks

    • #94645
      sofi_beker
      Participant

      HI,

      The code is working fine. however when it comes to shipping i mean only the shipping under “store settings”. when i want to submit a product it wont let me till I ALSO complete shipping on edit product. even though shipping class has been selected, dimensions and weight should not be a requierement as every product that vendors will sell will be diffrent.

      Therefore, i would like to ask you if you can exclude from shipping dimensions and weight.
      Thank you so much!

    • #94714

      Hi @
      we have updated the code in the previous reply ( #94362 ).Can you please check and keep us posted.

    • #94867
      sofi_beker
      Participant

      It’s working fine. Thank you so much!

      I would also like to ask you if you could create a code with a sign saying something like “Thank you for submitting” after the future vendor completes the registration form.

      Otherwise, after the vendor completes the form it’s not clear if it went trhough succesfully or not.

      Thank you again!

    • #94902

      @sofi_beker, may I know whether the “Approve Vendors Manually” option enabled in your site?

    • #94947
      sofi_beker
      Participant
      This reply has been marked as private.
    • #94974
      This reply has been marked as private.
    • #95007
      sofi_beker
      Participant

      Hi,

      I mean i would like that sign to appear IN after the vendor has completed the form application. To be more precise, after they click subimit.

      please see photo attached.

    • #95086

      @sofi_beker, I have forwarded this to our tech team.

      Once I have an update, will let you.

    • #95236

      Hi @
      For doing this you have to do some custom code. After registration, you have to redirect another page or any popup. you can use

      wcmp_vendor_login_redirect
      Copy

      this filter to redirect other page.

    • #95283
      sofi_beker
      Participant

      hi,
      please see photo attached. All i need is a message saying that the form was submitted i dont want to be redirect to any page.

      thank you.

      Attachments:
      Attachments:
    • #95409

      Hi @
      Currently, we are redirecting the page to the vendor dashboard if every data is right. If you want to modify and display some massage before the register button then use

      do_action( 'woocommerce_register_form' );
      Copy

      this hook.

    • #95411
      sofi_beker
      Participant

      My registration form is not redirecting me anywhere. that is what i am trying to explain you. nothing happens after the vendor completes the form. i just want a message saying that the form has been submitted please!

    • #95413
      sofi_beker
      Participant

      where do i need to paste that code? and in which line?

    • #95416

      @sofi_beker, by default we do direct the vendor in the dashboard page, as you can see : https://www.loom.com/share/71666de493444c0ab2bce0af2686b103

      If you are not getting this flow, then some plugin/theme conflict may cause this issue.

    • #95593
      sofi_beker
      Participant

      Hi,

      im not gettng this flow and i would like to fix it.

      pleae find the photo attached. at the moment, it looks like after the vendor submitts the form is redirected to login. How can i fix it?

      Which should be the correct code snipet?

      Thanks!

      Attachments:
      Attachments:
    • #95630

      Sofi, please disable all the plugin except WooCommerce and WC Marketplace for testing purposes and check again. If the issue still exist, please switch to some default theme like Twenty Sixteen and check again.

      Let us know the result so we can help you out further.

    • #95895
      sofi_beker
      Participant

      Hey problem is stil persisiting. how can i fix this ? thank you

    • #95964

      @sofi_beker, can you share a temporary admin, vendor and FTP access so we can look into this.

      While sharing the access, don’t forget to mark the response as private.

    • #95968
      sofi_beker
      Participant
      This reply has been marked as private.
    • #96011
      This reply has been marked as private.
    • #96085
      sofi_beker
      Participant
      This reply has been marked as private.
    • #96232
      This reply has been marked as private.
    • #96270
      sofi_beker
      Participant
      This reply has been marked as private.
    • #96401
      sumit singh
      Moderator

      Hi, The FTP access is not working in my end.
      Can you please check it once. I am sharing a video : https://www.loom.com/share/7a94a6ca3f2d4e14a4e8445215698a37

    • #97167
      sofi_beker
      Participant
      This reply has been marked as private.
    • #97176
      This reply has been marked as private.
    • #97210
      sumit singh
      Moderator

      @sofi_beker, I am disabling the plugins for testing purpose.

    • #97351
      sofi_beker
      Participant
      This reply has been marked as private.
    • #97361
      sofi_beker
      Participant

      hi guys! I really need this to be sort out. i got vendors waiting to be registered. thanks.

    • #97367

      Hi @sofi_beker,
      We have fixed this issue on your site. Now if a vendor registers then it successfully redirects to the dashboard page. Can you please check and confirm.

    • #97387
      sofi_beker
      Participant
      This reply has been marked as private.
    • #97388
      This reply has been marked as private.
    • #97724
      sofi_beker
      Participant
      This reply has been marked as private.
    • #97725
      sofi_beker
      Participant

      Guys what have you doneeeee? You completly fucked my website. Everything is missing. Ii have no currency, no footer, mi products are not properly displayed.

      You need to undo everything you have done right now!!!

    • #97739

      @sofi_beker, I am looking into this. Kindly provide me some time.

    • #97746
      This reply has been marked as private.
    • #97827
      sofi_beker
      Participant

      Hi,

      The sign of free shipping on products is not showing properly. for some reason, the photos are beeing displayed one below the other one and shouldn’t be like that.

      there are in extra cart at the bottom of the page thar shouldnt be appearing.

      My footer is empty! I don’t where all the information went. Can you please recover it?

    • #97918

      @sofi_beker, I am sorry but I am not able to find those issues.

      Can you please share the page link or video, so we can follow that to find the issues and help you out.

      Looking for your co-operation regarding the same.

      Also, are you referring to this add to cart: https://prnt.sc/sxov8e. IN that case that is coming from the theme, can you please check the theme settings and see whether they have any setting for this section?

    • #98063
      sofi_beker
      Participant

      yes i mean that cart. That wasn’t there before so we can to delete it.

      I have no video to show you because you delete it!

      My footer is gone and i need that to be recover immediately.

      Also, the products that have the free shipping sign are not displaying properly. photos are one below to the other one. we have to fix that too.

      please i have to solve this asap.

      thank you

    • #98104

      @sofi_beker, our replies are inline :

      – yes i mean that cart. That wasn’t there before so we can to delete it.

      >> As this portion comes from the theme, can you please ask theme whether there is any settings for this? Please do keep us posted.

      – I have no video to show you because you delete it!
      My footer is gone and i need that to be recover immediately.

      >> I understand your end, however we didn’t remove any footer, can you please check your site’s settings/theme settings regarding footer, may be there is something you need to set.

      – Also, the products that have the free shipping sign are not displaying properly. photos are one below to the other one. we have to fix that too.
      >> SOrry, can you please share the image again.

    • #98263
      sofi_beker
      Participant

      MY FOOTER IS GONE!!!!

      I USED TO HAVE PAYMENT OPTIONS WITH PHOTOS OF THE TYPE OF CARDS I ACCEPT AND THEY ARE NOT THERE ANY MORE. THAT IS ONE OF THE COLUMNS MISSING

      THE OTHER COLUMN MISSING IS THA ONE THAT HAD MY CONTACT DETAILS. EMAIL, PHONE!

      UNDO WHATEVER YOU DID!!! NOW!! YOU NEED TO FIX THIS ASAP PLEASE

    • #98363

      Hi @sofi_beker, we have added them to your site. You can also add them from this link: https://ecobuy.store/wp-admin/widgets.php
      Add the menu in the footer widget.

    • #98705
      sofi_beker
      Participant
      This reply has been marked as private.
    • #99359
      sofi_beker
      Participant

      Hi,

      I’m having problem to add a more complex shipping to my website. The vendor needs to be able to set up shipping rate according to weight ofproduct but that option is not appearing.

      How can he do this? the vendor needs to be able to see it and edit it from vendor dashboard.

      My developer tried to create a new shipping type in woocommerce and asigning it to a zone but did not work.

      Thank you.

    • #99400

      @sofi_beker, our plugin WCMp, provides the core shipping flow supported by WooCommerce i.e. Flat Rate / Free Shipping / Local Pick up.

      Now, our plugin Advance Shipping plugin(https://wordpress.org/plugins/wcmp-advance-shipping/) is compatible with WooCommerce Table rate shipping (https://woocommerce.com/products/table-rate-shipping/). Hence using these two plugin vendors can add shipping rate according to weight from their own shipping tab.

      Let us know if you have any further query.

    • #99478
      sofi_beker
      Participant

      Hi,

      I installed it in my website but it is not showing in vendor dashboard so vendor cant edit it. Would you mind checking why? My web developer couldnt find a solution.

      thank you!

    • #99947
      sofi_beker
      Participant
      This reply has been marked as private.
    • #99950
      This reply has been marked as private.
    • #99951
      sofi_beker
      Participant
      This reply has been marked as private.
    • #99992
      This reply has been marked as private.
    • #100090
      This reply has been marked as private.
    • #100173
      sofi_beker
      Participant

      now it is. thank thank you.

    • #100198

      @sofi, I am sorry, but has the issue been resolved?

    • #100201
      sofi_beker
      Participant

      not yet. I’m still trying to find the solution.

      this is the porblem of my vendor:

      instead of using weight to determine our shipping, we set our shipping cost table using product price.

      For example, $1-$30 will cost you say … $6 to ship within Victoria

      Obviously $1-$30 will correspond to our products, taking into product weights into account.

      If someone buys 1 bar of soap, it will cost $6 to ship in Victoria. If someone buys our $30 gift set, which contains 3 soaps and a pretty wooden box, the $6 shipping fee will still cover it within Victoria.

      So our shipping is based on price, not weight.

      how can we find a solution for this vendor please?

    • #100374
      sofi_beker
      Participant

      hi guys,

      my venors have been waiting for a solution for more than 3 weeks now! how can i solve this problem of shipping>?
      thank you

    • #100413

      Sofi, you are using the table rate plugin of this plugin author: https://bolderelements.net/

      Whereas, our addon WCMp Advanced Shipping plugin is compatible with WooCommerce Table rate shipping (https://woocommerce.com/products/table-rate-shipping/). That is why the vendor is not able to access the “Table rate” shipping method (see the attachment).

      Can you please use WooCommerce Table rate shipping and check again.
      Please do keep us posted.

    • #100460
      sofi_beker
      Participant

      okey. but you told me this plugin is free and accoring to the link you sent me i should pay for it. Is there a free option to solve this?

      Thank you.

    • #100532
      sofi_beker
      Participant

      hi,

      1) I’m still waiting for the response from above.

      2) You told me 2 weeks ago you fix the problem of the vendor registration form. I tested and still no sign of form beeing completed! WHATS GOING ON?

    • #100536

      Sofi, our replies are inline :

      1) I’m still waiting for the response from above.

      >> If you check the thread (https://wc-marketplace.com/support-forum/topic/vendor-requirements/#post-99400), you can see that we can share the link of WooCommerce Table Fate shipping which is available in WooCommerce’s own site.

      2) You told me 2 weeks ago you fix the problem of the vendor registration form. I tested and still no sign of form beeing completed! WHATS GOING ON?

      >> You have set the wrong pages, hence these issues.
      This is a Vendor dashboard page: https://ecobuy.store/wcmp/

      vendor registration page: https://ecobuy.store/vendor-registration-2/

      As you can see, it is working as per our flow: https://www.loom.com/share/5166ae2d579745108e53330fb03565b2

      Now, you can rename the slug as per your need, but don’t change the page name.

    • #100669
      sofi_beker
      Participant

      HI,

      1) I think this plugin is already install. Could you please help me out so that it does appear in vendor dashboard and they cans et it up please?

      2) Sorry but what is the slug? I tried to create a new vendor by completing the form buy you just deleted. now is not showing and it says invalid page… please test things before changing them cause im not a developer i dont know how to fix this now

    • #100708

      @sofi_beker, our replies are inline :

      1) I think this plugin is already install. Could you please help me out so that it does appear in vendor dashboard and they cans et it up please?

      >> I checked again, as you can see this is not the one by WooCommerce : https://prnt.sc/thlvxm

      So, please deactivate this plugin and use the plugin, that we have shared, i.e. https://woocommerce.com/products/table-rate-shipping/

      2) Sorry but what is the slug? I tried to create a new vendor by completing the form buy you just deleted. now is not showing and it says invalid page… please test things before changing them cause im not a developer i dont know how to fix this now

      >> The slug is : https://ecobuy.store/vendor-registration-2/

      As you can see, it is working fine: https://www.loom.com/share/6716319404534ee7b3d4ed4d99d4161a

    • #100739
      sofi_beker
      Participant
      This reply has been marked as private.
    • #100753
      sofi_beker
      Participant
      This reply has been marked as private.
    • #100833

      @sofi_beker, WooCommerce Table Rate shipping is not available over WordPress.org
      You need to get this plugin from here as shared in this thread also: https://woocommerce.com/products/table-rate-shipping/

    • #100851
      sofi_beker
      Participant

      ok. what about the other question i did? The sign is still not there…

    • #100879
    • #100940
      sofi_beker
      Participant

      Can you please see the photos that i send attached? There is NO SIGN!! stop sending me the same file without reading what i write! I can’t add new vendors now!

    • #100941
      sofi_beker
      Participant

      https://www.loom.com/share/6716319404534ee7b3d4ed4d99d4161a

      In this video that you sent me there is not SELL ON ECOBUY SIGN! you removed from my website. PLEASE PLEASE SEE PHOTOS ATTACHED.!!!

    • #100951

      Sofi, the only pages I deleted was duplicate registration page : https://prnt.sc/tjfbyf

      Now, you can create a registration page on our end, just like the one I did : https://ecobuy.store/vendor-registration-2/
      You can simply change the name to “SELL ON ECOBUY SIGN!”of this page too,

    • #101054
      sofi_beker
      Participant

      Ok, but i don’t know how to do that and now the registration form it’s not shoing in home page. If you can just create the page “sell on Ecobuy” on the footer under the colum OUR COMPANY I Willl be happy with that and close this conversation. Thank you so much.

    • #101191
      WCMp Support
      Keymaster

      Hi Sofi,

      Wish I could help you, but frankly speaking this needs additional coding effort 🙁 Would request you to please hire a developer and get this done. Please feel free to ping us, in case you need any further support.

Viewing 80 reply threads

Please LOGIN to reply to this topic

COVID-19 Outbreak: WCMp team is supporting business affected by coronavirus

Read the Message Buy at Slashed Price