Shipping issue

WCMp Stripe Marketplace

Shipping issue Open

Viewing 15 reply threads
  • Author
    Posts
    • #97747
      William
      Participant

      Hi,

      I want admin to recieve the price of all shippings, and I do not want to set a shipping price per vendor. So I do not want to activate Vendor Shipping.

      However when I process a payment, Stripe does not process the shipping price, even if it is included in the order.

    • #97767

      @William, sorry for the inconvenience.

      Our team is looking into this.
      Kindly provide them some time.

    • #97768
      William
      Participant
      This reply has been marked as private.
    • #97843
      William
      Participant

      Hi, did you get to reproduce the issue?

    • #97850

      Yes, William, we are able to recreate this on our end.

      I will be able to give you the fixed plugin within a day.

    • #98037
      William
      Participant

      Hi, sorry but I haven’t heard from you yet. Did you fix the issue?

    • #98066
      This reply has been marked as private.
    • #100889
      Anika Ali
      Participant

      Hi,

      I am facing the exact same issue, have sent support ticket with no response.

      Did you get this resolved?

      Thanks

    • #100895

      Anika, I have shared the fixed plugin via mail.
      Can you please check.

      please do keep us posted.

      • #101165
        Anika Ali
        Participant

        Hi,

        Please can you send again as i did not get anything.

        Thank you

    • #101064
      Anika Ali
      Participant

      I haven’t received any emails or reply back to my support emails

      Please can you send the fixed plugin again, maybe this fix should be provided universally so all users who have purchased this plugin?

      Thank you

    • #101065
      William
      Participant
      This reply has been marked as private.
    • #101163
      Anika Ali
      Participant

      Hi Willam,

      I cant see the reply as it is marked as private. Can you let me know if this issue has been fixed for you?

      Also @neha I have not received a reply back to my support or the fixed plugin stated in the previous message on this thread.

      Can you send it again? I need a fix urgently as this plugin is not working.

      Thank you

    • #101168
      Fantastic Kuhu
      Keymaster

      Anika, the team shared the plugin file over chat support.

      let us know if you need any further help.

    • #101174
      Anika Ali
      Participant

      Hi,

      Just to update others who might be reading this thread and also facing this issue:

      I have activated your plugin fix but it has not resolved the issue.

      The customer is not being charged for shipping. It displays the shipping cost in the Order confirmation email however when I login to my Stripe dashboard, I can see the Vendor gets his commission, the admin gets his commission but does not get the shipping cost. Upon checking my test card payment, I can see the shipping was not charged to the test order.

      Support has requested my logins details which has been provided. Waiting for them to login and test.

      Thank you

      • #101208
        WCMp Admin
        Keymaster
        This reply has been marked as private.
        • #101227
          Anika Ali
          Participant

          Hi,

          The fixed plugin did not resolve the issue.

          The shipping charge is still not being charged to the customer.

          Kind regards

    • #101264
      Fantastic Kuhu
      Keymaster

      Can you please enable these 2 options to get shipping on stripe. Please check below link
      https://prnt.sc/tl9nne
      https://prnt.sc/tl9o6z

      Let me know the status please.

      • #101294
        Anika Ali
        Participant

        Hi Neha,

        Shipping should go to admin. The vendor should simply get the product sale commission e.g 10% or even 100% however shipping should go to the admin and not vendor.

        I did test with those 2 options checked and shipping did get charged to the customer this time but the vendor received the shipping cost which is not what we want.

        What should happen:
        Product 1 cost £10 + £5 shipping
        Product 1 is set to Vendor 10% commission.

        After purchase:
        Vendor should get: 10% (of product) = £1
        Admin should get 90% (of product) + 100% of shipping = £9 + £5 shipping.

        With your options provided in the previous message, the vendor is getting the 10% and the shipping which is incorrect since that should go to admin.

        Thank you

    • #101364
      Anika Ali
      Participant

      Hi Neha,

      I have fixed the issue myself and everything is working as we wanted.

      In our case it was a plugin conflict with “Hide My WP” which when disabled everything worked fine. I guess it had something to do with the Settings > Config redirect URI and our /wp-admin URL being changed to something else therefore it was not being able to callback or redirect back correctly as /wp-admin did not exist.

      At the moment we have disabled Hide My WP plugin and contacted the plugin support for assistance. Once they have replied, I will update this thread incase others are also facing the same issue as me.

      Thank you

Viewing 15 reply threads

Please LOGIN to reply to this topic

COVID-19 Outbreak: WCMp team is supporting business affected by coronavirus

Read the Message Buy at Slashed Price