WCMp bundle is available at a slashed price

Grab It Now

Remove items from add product form to simplify it for user

Remove items from add product form to simplify it for user2019-09-17T18:13:30-05:00

Home Support Forum WCMp Advanced Frontend Manager Remove items from add product form to simplify it for user

WCMp Advanced Frontend Manager

Remove items from add product form to simplify it for user Open

  • Author
    Posts
  • info39
    Participant
    Post count: 58

    Hi I would like to simplify my add product form.

    I intend to remove all shipping and other options, so that the user just enters a title, description etc and then price and images, and the various taxonomies under which it will be searchable, and that’s it. No need to pick category,

    How do I remove the category section? I opened up edit-product but it wasn’t clear what to remove in there to achieve that when a user clicks edit product front end, they don’t have to worry about category it just defaults to the only available category and they just go straight to the screen with the title to add etc etc. I played around trying a few things but nothing I removed seemed to work, can you shed any light?

    Many thanks

  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381

    Hi @info39, not to worry.

    Can you share exactly what fields you want to remove and corresponding screenshots, so we can help you out accordingly.

  • info39
    Participant
    Post count: 58

    Hi there, thank you for your message, the main thing is how to remove the entire category section.

    Immediately after clicking ADD PRODUCT you land on the page att SCREEN 1. ‘Step 1 of 2’ it’s called in the edit screen.

    I would like to land on the page att (see next post as I think you can only add 1 image per post) – SCREEN 2 when you click ADD PRODUCT. ‘Screen 2 of 2’ it’s called in the edit screen. And of course I will have to remove the bit about Screen 2 of 2.

    Kind thanks for your help.

    Attachments:
  • info39
    Participant
    Post count: 58

    Screen 2

    Attachments:
  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381

    @info39, you can easily disable this category selection, all you have to do is goto WCMp >> Settings >> General and enable the option called “Disable Advance Marketplace Product Listing” (see this scrrenshot – https://prnt.sc/p81svg)

    Can you please check this option and let us know.

  • info39
    Participant
    Post count: 58

    Hi there, okay thanks I have tried that but it doesn’t remove it I’m afraid.

    I deleted cache and waited a while, and then I logged out and then in again when it hadn’t worked to check, but still no luck unfortunately.

    I don’t have anything in my child theme overriding it, I checked that also.

    Could I be doing something else wrong?

    Thank you

  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381

    @info39, sorry to hear that.

    Can you share a temporary admin, vendor and ftp access of your site so that we can check.

    While sharing the access donโ€™t forget to mark the response as private.

  • info39
    Participant
    Post count: 58

    Hi there ah no sorry that’s not possible for me to do in this case as the site’s confidential, which is rather annoying because I would love to as I could really do with the help because this has sucked up a lot of time! ๐Ÿ™

    Is there anything you can think of I could try? OR perhaps I could just override in the child theme add-product and remove the category wrapper? Would that be possible?

    ๐Ÿ™

  • info39
    Participant
    Post count: 58

    Oh OOPS didn’t mean to double-up on the sad face there above haha I’m not quite THAT sad (yet! although if I can’t work out what I’ve done wrong in the next hour I might have to jump up and down on my laptop ahaha!)

    Anyway here is a screen shot of my options att

    Thanks

    Attachments:
  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381

    @info39, can you do a small test and share the video capture.

    Therefore disable all the plugins except WooCommerce, WC Marketplace and then follow this suggestion : https://wc-marketplace.com/support-forum/topic/remove-items-from-add-product-form-to-simplify-it-for-user/#post-74158

    We will wait for your reply.

  • info39
    Participant
    Post count: 58

    Ok this is weird, but if I disable the advanced front end manager plugin then this works!

    Although, I will need to get rid of where it says ‘Step 2 of 2’ at the top.

    But yes now it works!

    As do some other changes I couldn’t make – like removing the advanced tab with that function, that now also works, and removing media buttons! None of that worked until I removed the plugin. Why would this be?

    Thanks

  • info39
    Participant
    Post count: 58

    Additionally, can I check the resultant behaviour of clicking to check this option:

    ‘Disable advance marketplace product listing flows like popular ecommerce site.’?

    Does it send you straight to the template EDIT PRODUCT instead of ADD PRODUCT?

    If so, if you navigated for instance, to ADD PRODUCT even with this clicked so that the ADD PRODUCT sent you to EDIT PRODUCT (ie step 2), you would still reach the ADD PRODUCT if you navigated to it specifically in the url bar, wouldn’t you?

    Thanks

  • info39
    Participant
    Post count: 58
    This reply has been marked as private.
  • info39
    Participant
    Post count: 58
    This reply has been marked as private.
  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381
    This reply has been marked as private.
  • info39
    Participant
    Post count: 58
    This reply has been marked as private.
  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381
    This reply has been marked as private.
  • info39
    Participant
    Post count: 58
    This reply has been marked as private.
  • info39
    Participant
    Post count: 58
    This reply has been marked as private.
  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381
    This reply has been marked as private.
  • info39
    Participant
    Post count: 58
    This reply has been marked as private.
  • NerdySupportExpert Moumita
    Keymaster
    Post count: 5381
    This reply has been marked as private.

Please LOGIN to reply to this topic