WCMp bundle is available at a slashed price

Grab It Now

Conflict with YITH Social plugins because of Library loaded wrong way

Conflict with YITH Social plugins because of Library loaded wrong way2019-01-10T15:30:51-05:00

Home Support Forum WCMp Vendor Membership Conflict with YITH Social plugins because of Library loaded wrong way

WCMp Vendor Membership

Conflict with YITH Social plugins because of Library loaded wrong way Open

Tagged: 

  • Author
    Posts
  • Michaelgimm
    Participant
    Post count: 36

    Hi WCMp
    I have been in contact with YITH because a plugin I use “YITH Social Plugin premium” is causing an error after WordPress update.
    They say the error is because of something you do.

    I wrote this to YITH
    Hi YITH
    I found that there is both a conflict in KingSUMO plugin and in YITH plugin, even before update to WP 5.0.
    First I disabled KINGSUMO and then updated YITH Social. After updating YITH Social, this error was shown in top of screen.

    This is the error:
    Warning: include(/home/weensu94/staging/2/wp-content/plugins/yith-woocommerce-social-login-premium/includes/hybridauth/vendor/composer/../../hybridauth/Hybrid/Endpoint.php): failed to open stream: No such file or directory in /home/weensu94/staging/2/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader.php on line 444

    Warning: include(/home/weensu94/staging/2/wp-content/plugins/yith-woocommerce-social-login-premium/includes/hybridauth/vendor/composer/../../hybridauth/Hybrid/Endpoint.php): failed to open stream: No such file or directory in /home/weensu94/staging/2/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader.php on line 444

    Warning: include(): Failed opening ‘/home/weensu94/staging/2/wp-content/plugins/yith-woocommerce-social-login-premium/includes/hybridauth/vendor/composer/../../hybridauth/Hybrid/Endpoint.php’ for inclusion (include_path=’.:/usr/local/php71/pear’) in /home/weensu94/staging/2/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader.php on line 444

    Warning: Cannot modify header information – headers already sent by (output started at /home/weensu94/staging/2/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader.php:444) in /home/weensu94/staging/2/wp-admin/includes/misc.php on line 1126

    YITH wrote this
    Hi Michael,
    i found the culprit. I have deactivated all plugins leaving only WooCommerce + Social Login + Yoast + King Sumo and the issue was not occurring. I have enabled them one by one and i found that the issue comes from the plugin WCMp Vendor Verification which has the same library of Social Login plugin but it is loaded in a forced way.

    Regards,
    Alberto Ruggiero

    I wrote them back
    Ok, so how do I solve this? What is the right solution?

    YITH replied
    Hi Michael,
    i suggest you to contact the developer of this plugin in order to make that library only when needed. We remain at your disposal for any clarification.

    Regards,
    Alberto Ruggiero

    END of correspondence

    What would you say about that?

    Cheers
    Michael

  • Tech Tycoon Debleena
    Keymaster
    Post count: 501

    @Michaelgim, our team will look into this.

    I will keep you posted.

Please LOGIN to reply to this topic